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Problem

Mail retrieval is very slow, and/or blocked/stopped.

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Jira is responsible for pulling mail from the mailserver, which then invokes JEMH. Sometimes not all the email content is available directly, and to avoid arbitrary failures in later retrieval, JEMH will cause the full email content to be retrieved and stored as part of auditing (is JEMH auditing enabled?). If you see a JEMH auditing entry but with non-success outcome linked to the times involved, its possible there is a processing problem. If you see a JEMH auditing entry with only success then JEMH is doing the expected thing, and the problem you see relates to retrieval.

Check your logs

See atlassian-jira-incoming-mail.log on all your DC nodes, repeating stack traces should help you identify the cause.

Common Causes

Database connectivity issue causes scheduled jobs to break

You are using IMAP and large emails are very slow

Its possible that large emails take a really long time due to default data batch sizes. Large mail can take excessively large time to download. JEMH Processing Reports have a Performance section that highlight download time as well as processing time (requires JEMH auditing enabled!)

Jira Quartz Scheduler has all threads blocked with mail retrieval

We have seen that in some cases

Setup Diagnostics

Enabling Auditing - check Outcome

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Related issues