Event Listener JSD issue transition notifications do not send if a comment is present in the transition

Problem

When the JEMH Event Listener is configured for a Jira Service Desk project, if an issue transition occurs with a comment present because one was defined in the issue transition screen, the JEMH Event Listener will not send email notifications to any issue participants.

Cause

Due to limitations in the Jira Service Desk API, there is no guaranteed way to determine the public/private nature of a JSD comment when an issue event fires. Race conditions exist that mean JEMH cannot accurately determine comment visibility, this is a bug within the Jira Service Desk product. In some areas JEMH is able to work around these race conditions, however in this specific case there is currently nothing we can do. JEMH is preventing the notification from being sent because we cannot determine if the included comment should be private, we take the safest approach and do not send the notification to protect the potentially private comment from leaking.

The Jira bug can be found here: JSDSERVER-3533

Solution

There is currently no workaround or solution for this issue. Please upvote the Atlassian issue linked above.

https://thepluginpeople.atlassian.net/browse/JEMH-6266